Cricut all of a sudden going at a super slow speed

Two Peas is Closing
Click here to visit our final product sale. Click here to visit our FAQ page regarding the closing of Two Peas.

Posted 2/10/2013 by Himpossible! in General Scrappin'
 

Himpossible!
PeaAddict

PeaNut 121,039
December 2003
Posts: 1,763
Layouts: 2
Loc: Central Florida

Posted: 2/10/2013 2:21:49 PM
My circuit was working, but the next time I pulled it out to use it, it is still cutting but acting 'like the batteries are running down'. Even thought its not on batteries but plugged in. Any ideas?! Has this ever happened to anyone before?

Thanks!


Wife and mommy to my precious boys
DS adopted, home from S. Korea 9/22/05!!!

1st 5K completed 11/13/10, 33:03. Went way to fast!!!
1st 10k...looking for one
1st 1/2 marathon...completed 2/27/11!!!

Sparehead3
StuckOnPeas

PeaNut 446,722
November 2009
Posts: 2,649
Layouts: 5
Loc: PNW USA

Posted: 2/10/2013 2:43:08 PM
Did the speed setting get changed on accident, my kids "love" to adjust my Cricut settings for me...

Himpossible!
PeaAddict

PeaNut 121,039
December 2003
Posts: 1,763
Layouts: 2
Loc: Central Florida

Posted: 2/10/2013 7:07:46 PM
No, speed changes have not been changed. I did double check that. I probably need to call them, as I think somehow the motor is bad? It's a few years o,d, but I really haven't used it all that much (as I scrap in spurts!). I'm really wanting to use it more!


Wife and mommy to my precious boys
DS adopted, home from S. Korea 9/22/05!!!

1st 5K completed 11/13/10, 33:03. Went way to fast!!!
1st 10k...looking for one
1st 1/2 marathon...completed 2/27/11!!!
Show/Hide Icons . Show/Hide Signatures
Hide
{{ title }}
{{ icon }}
{{ body }}
{{ footer }}