My Selphy stopped working! :(

Two Peas is Closing
Click here to visit our final product sale. Click here to visit our FAQ page regarding the closing of Two Peas.

Posted 3/10/2013 by paperpilekitten in General Scrappin'
 

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/10/2013 7:28:21 AM
So, the fun is apparently over.

My Canon iEpp cannot find the printer anymore.
I have unistalled and reinstalled the iPhone app.
I have restarted the phone, the printer, the app, our wi-fi router, several times each.
I have disconnected and reconnected all devices to the wi-fi.
My DH downloaded the app but his app doesn't find the Selphy either.

Nothing!

It printed one photo today and when I would print the next photo, the connection just died.

I remember that someone here had the same problem? Did you ever find any solution?

ETA: I can't print from my computer either. Not wirelessly and not with the USB cable. It's really as the printer is completely gone. But it shows up as connected to the wireless network in our home, so it is there somewhere. It's just that any other device can't seem to find it.

JavaJones
BucketHead

PeaNut 14,590
April 2001
Posts: 755
Layouts: 0

Posted: 3/10/2013 11:31:14 AM
Did you try to update the drivers on the printer? That might help. So sorry it isn't working for you!

thekatsmeow
StuckOnPeas

PeaNut 347,059
November 2007
Posts: 2,140
Layouts: 138
Loc: Bremerton, WA

Posted: 3/10/2013 2:49:02 PM
Oh No! How long have you had it? Did you contact Canon? Are they any help at all?

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/10/2013 5:18:04 PM
I gave up for today and just hoping it will 'magically' work tomorrow. If it doesn't I'll have to call Canon Support and see if they have any advice (probably not).
I just discovered a thread on the Cat Color Atelier boards and it seems as if many people have the same problem with Selphy. They just keep turning on and off the printer and the phone and wifi routers and then, if you're lucky (obviously I wasn't), the Selphy might 'magically' reappear in the print app. Ugh.
And I thought Canon made high quality devices...

ratqueen
I drank the whole fairy.

PeaNut 233,449
November 2005
Posts: 7,118
Layouts: 19
Loc: Here+There

Posted: 3/10/2013 10:15:35 PM
Mine stopped working today too. The signals get through to it but the second it starts to print something the printer shuts off I'm going to call Canon tomorrow.

loveforpitbulls
PeaNut

PeaNut 577,998
January 2013
Posts: 253
Layouts: 5
Loc: Northern California

Posted: 3/10/2013 10:31:32 PM
Mine stopped printing as well. I have started loading pictures on a falsh drive and plugging that into the printer directly. Gets the job done, but the whole wireless aspect is basically pointless now.

ratqueen
I drank the whole fairy.

PeaNut 233,449
November 2005
Posts: 7,118
Layouts: 19
Loc: Here+There

Posted: 3/10/2013 10:49:25 PM
I tried putting the pictures on an SD card and plugging it into the printer, but mine still shut off

doesitmatter?
Ancient Ancestor of Pea

PeaNut 509,811
May 2011
Posts: 6,639
Layouts: 27

Posted: 3/10/2013 10:57:10 PM
Ok they all stopped working today? Was their update that crashed them all? Pretty sure I read at SC that one or two won't print wirelessly as of today as well? Weird, very weird.

gale w
shiny farmwife

PeaNut 40,275
June 2002
Posts: 23,848
Layouts: 52
Loc: Indiana

Posted: 3/11/2013 12:23:56 AM
Well this is weird. I don't have a wireless selphy so I haven't had a problem but I was hoping to save up for one. If it's going to just quit working maybe I won't.

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/11/2013 1:43:20 AM
I have a suggestion to what it could be! I told my DH that we all have the same problem, and then he said that's a classic Daylight Saving Time bug! And that Canon need to update their firmware. I haven't got a clue what that means but I'm going to send an e-mail and report it to Canon customer support. I hope that you all do the same, because if they get loads of e-mail from grumpy scrappers they might speed up that process.

DH said he didn't think of it yesterday because in Europe, we don't change to DST until March 30. Love him for (hopefully) solving this mystery!


ScrappykindofGirl
StuckOnPeas

PeaNut 365,303
March 2008
Posts: 2,198
Layouts: 102
Loc: The Sunshine State

Posted: 3/11/2013 5:53:34 AM
Thank you Peas for posting this! I spent 2 hours last night trying to fix mine and nothing worked!

Please update if anyone gets word from Canon.
Uploaded with iPhone client

ratqueen
I drank the whole fairy.

PeaNut 233,449
November 2005
Posts: 7,118
Layouts: 19
Loc: Here+There

Posted: 3/11/2013 10:38:02 AM
I talked to Canon this morning and in my case it's a hardware issue. I have to send my Selphy to the Canon doctors in New Jersey to fix it. I have to pay to ship it there too, which stinks... the printer is less than 2 months old. I told the guy I had wasted a bunch of photo paper trying to get it to work and he's going to send me a 36 pack of paper/ink, so that offsets my shipping cost

I asked him about the wireless stuff for you guys. He said he didn't know of any specific bug but the first troubleshooting they would do is to have you reset both the printer and your router.

To reset the printer:
Turn it off
Unplug the AC adapter from it.
Press and hold the power button for 2 seconds, repeat for a total of five times. (5 2-second bursts)
Plug the printer back in and power it on.

TO reset your router (YMMV):
Unplug the router, let it sit and think about all the wrong it's done in its life for 30-40 seconds.
Plug it back in to teach it a lesson.
Once it's back up and running check the LAN settings on your Selphy to make sure its IP is populating in your network.

Hope that helps somebody.

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/11/2013 10:42:45 AM
Thank you so much, ratqueen, for asking Canon and posting here! I'm going to try those tips!
But it also seems likely that it could be a general firmware bug. Why would all our Selphys stop working on the same day? That has to be more than coincidence, I'd think.

Miss Kathy
AlienGreenPea

PeaNut 309,431
April 2007
Posts: 508
Layouts: 1

Posted: 3/11/2013 3:22:06 PM
I don't have a selphy but my wireless system acted up all day yesterday ,cycled on and off, but is working fine today. Makes me wonder about Daylight Savings Time too.

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/12/2013 4:42:56 AM
Anyone here who got their Selphy to work again? If so, what did you do to make it work?

ETA: After posting I tried several different things once again and the Selphy prints from a USB stick! Hooray! But wireless (wi-fi or ad hoc) still not working, no matter what I do.

Here's what happened earlier today:
I spoke to the Canon customer support in Germany and the technician agreed that it's most likely a firmware problem and gave me the number to the local Swedish customer support.
Well, they don't really have any CS here but came to the conclusion that they would give me a new Selphy if I drive to their office outside town. It will take them 2 weeks to get me a new one because they don't have any products in stock at the office, so I'll have to go twice and that will cost me money. No thanks!
Because there are no guarantees that the new one will work, as it has the same firmware installed. If the new one doesn't work either I will have to repeat the same procedure "until Canon realizes that they should do something about the problem with the firmware". Yes! That's actually what they told me!!

So, then I called the store where I bought it. They will take it to a third party service shop that will look at it (and won't have the slightest clue what happened anyway), but I won't get a new one from them.

Ugh. Come on!

I think that I will just let my Selphy sit for at least a month before I take it to the local Canon office, and see if Canon US comes out with any firmware upgrade that I can download and install myself. I guess that if they get a lot of complaints that might make them start working on a solution.

Or, maybe the Selphy wireless system will start working again in November when DST is over? lol!

Well, I got about 6 or 7 photos printed for $150. That is definitely the most expensive photo prints I've ever made.

ETA: But it works with a USB stick now. wahhooo! Better than nothing.


JavaJones
BucketHead

PeaNut 14,590
April 2001
Posts: 755
Layouts: 0

Posted: 3/12/2013 6:27:11 AM
Just a thought, if it might be a dst issue with the firmware, try changing the time temporarily on your phone and/or computer and try to print. If you can print after changing the time on your devices, then at least you will know what the problem is for sure...I have been wanting to get a Selphy to print photos from my iPhone, so I am watching this thread closely. So sorry you and other Selphy owners are having all these problems!

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/12/2013 6:53:56 AM

try changing the time temporarily on your phone and/or computer and try to print.


Yup, I have tried that too. It didn't work. I think I have tried every possible way by now. I'm exhausted and got a headache. Feeling like Don Quijote or something. lol!

Well, as I said - I will probably wait for a while and see if a solution comes up - otherwise I might take it back and get a new printer to try out. But as long as I can print the photos from a USB stick, it's at least a little bit better than nothing.

Thescrappyone
PeaNut

PeaNut 498,047
February 2011
Posts: 215
Layouts: 0

Posted: 3/12/2013 9:05:26 AM
I tried mine this morning and i could print from my iphone wirelessly .
If it is the DST wouldnt it affect everyone ? My phone automatically sets to DST I sure hope you all get a fix soon.

Molitva
BucketHead

PeaNut 479,819
August 2010
Posts: 812
Layouts: 15
Loc: PTC, GA

Posted: 3/12/2013 11:15:43 AM
I haven't had my printer on in about a month. Now I'm afraid to turn it on incase it goes bonkers too

Watching this thread for updates.

Simplej0ys
PeaNut

PeaNut 558,342
June 2012
Posts: 286
Layouts: 0

Posted: 3/12/2013 11:08:50 PM
I'm watching this too. I was about to purchase the 900 for myself
Uploaded with iPhone client

CaribbeanGirl
AncestralPea

PeaNut 559,480
July 2012
Posts: 4,259
Layouts: 88
Loc: Hogwarts

Posted: 3/12/2013 11:11:39 PM
I used mine the last few days and it has worked great. Hate you guys are having trouble.
Uploaded with iPhone client

biochemipea
likes shiny things

PeaNut 114,614
November 2003
Posts: 22,668
Layouts: 499
Loc: Ontario, Canada

Posted: 3/13/2013 10:27:57 AM
Wow, I'm really disappointed for all of you to hear about these problems. And especially, I think, Canon's lack of helpful customer service. There is no way you should be paying for shipping it back, or driving hours out of town repeatedly to get THEIR poor printer made useable again!

I have been considering investing in a Canon Selphy after reading all of the rave reviews here at 2Peas, but will definitely continue to hold out now.


lovetodigi
Ancient Ancestor of Pea

PeaNut 257,022
April 2006
Posts: 8,640
Layouts: 5
Loc: USA

Posted: 3/13/2013 11:39:38 AM
Maybe there is a connection between the ones that quit working verses the ones that are still working. Perhaps it is a glitch with just one shipment or one manufacturing run of the Selphys. When did everyone that is having problems buy their printer?

I haven't checked mine yet to see if it is working or not, but I will check it sometime today and report back. I bought mine in Dec. at Best Buy.

ETA: I did have trouble getting mine to be recognized by my computer a few days ago, before the time change. Figured out that the printer was not connecting to the WIFI network, even though it showed on my computer that it was available. When I tried to print, it would try for a bit and then come back and say, not connected. I had to redo the steps on the menu on the printer to set up the network, including the WIFI password, and then it worked. Don't know if that helps anyone or not.

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 3/13/2013 11:49:43 AM
I have filed a support ticket with Canon US yesterday. I'm not really supposed to, because I don't live in the US but somehow I slipped through the net and I'm grateful, because their CS in Germany couldn't offer any help and the Swedish CS was a joke.

With the help of Canon CS I have managed to extract the error code from the printer, and to me it looks like the printer connects but then immediately is told to shut down by the iPhone app (or if it's vice versa). So now I'm waiting for Canon to get back to me, hopefully with a solution!

I am determined to sort this out because I want my wireless printer connection back! Printing from the USB stick is all right but I bought the printer because of the wireless option! Other than these recent problems, I still love my Selphy and I love the photo print quality. Just waiting to get the full functionality back.


Gem Girl
PeaAddict

PeaNut 460,363
March 2010
Posts: 1,482
Layouts: 7
Loc: Lost in thought

Posted: 3/13/2013 3:30:21 PM
I don't know what operating systems any of you are running, but when I was researching photo printers I found that the Selphy doesn't run Windows 8, indicating that they don't plan to continue to support it in the future. That made it a no-go on my prospect list.

Regardless, I'd be hopping mad if a pricey new gadget went loopy on me like you're enduring. Hope they make it right for you.

ratqueen
I drank the whole fairy.

PeaNut 233,449
November 2005
Posts: 7,118
Layouts: 19
Loc: Here+There

Posted: 3/14/2013 2:40:05 PM
Just thought I'd post an update - my printer arrived at Canon's repair facility this morning. They verified the issue and are sending me a new printer rather than fixing mine. My photo paper kit also arrived by ups today. So while it is an issue - the solution is only taking 3 days + shipping time. I'm pretty satisfied with that.
Uploaded with iPhone client

ScrappykindofGirl
StuckOnPeas

PeaNut 365,303
March 2008
Posts: 2,198
Layouts: 102
Loc: The Sunshine State

Posted: 3/15/2013 8:07:51 PM
Mine works again! Hooray! I re-booted my router and had to re-enter the WEP password. Good luck, Peas!
Uploaded with iPhone client

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 5/11/2013 10:19:01 AM
After a long mail conversation with Canon support they basically told me that they had no idea why it didn't work with the iPhone app or computer and recommended me to exchange it for a new one. To do that, I would have to rent a car and drive to their local office. Two times! Because they wanted me to leave my Selphy with them at one time and then they would order a new one, which would take 1-2 weeks.

No, thanks. Thought I'd settle for printing from USB stick. Wasn't happy, but at least I could get it to print.

Today I thought I would try using the iPhone app again, just for kicks. It's been 2 months, who knows, maybe something magically happened? So I opened the app, and now it's working!! How is that possible?? I have to restart the app for every third photo I print, and sometimes it loses the connection, but it works! I'm just stunned. lol!

Apparently, you have to be very patient with a Selphy.


Anna in TX
StuckOnPeas

PeaNut 23,002
October 2001
Posts: 2,336
Layouts: 11
Loc: TX

Posted: 5/11/2013 3:09:57 PM
I'm glad you sort of got it working, OP! I have never been able to get my Selphy to print wirelessly. I have to plug it in to my computer to do anything.

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 5/11/2013 5:25:45 PM
I'm sorry to hear that, Anna. I love the print quality of the photos, but that wireless feature doesn't seem to be reliable at all.


pieces-of-me
BucketHead

PeaNut 276,171
September 2006
Posts: 933
Layouts: 2
Loc: The Granite State

Posted: 8/15/2013 6:46:17 PM
So, I had the same problem as Margareta.....my Selphy worked great, then I upgraded my iPhone 5 to ios6 when it came out, didn't use the Selphy for 4-5 months, just took it out and nope, won't print. Says printer not connected to Wi-Fi, cannot find printer. It is clearly connected to the Ad Hoc Wi-Fi. I tried re-installing the app, tried to recreate the wireless settings/connection. Nothing.

I called Canon USA Tech Support and after trying everything under the sun we figured out a way to make it communicate. On the iPhone under Settings; Wi-Fi, choose the CP900 network, then hit the blue arrow key on the right, scroll down to Renew Lease, click on it. Then go back to the Wi-Fi screen by the back arrow, don't use the home button. Make sure you are still connected to the CP900 network. Open the Canon iEPP app, choose a picture, hit the CP 900 button that is highlighted, this will bring you to the detect printer screen where you should see the CP900 printer button highlighted in green, click on it, will bring you back to the print screen. Hit print. More steps than it used to be but it WORKS!!

NoWomanNoCry
PeaAddict

PeaNut 366,645
March 2008
Posts: 1,517
Layouts: 4
Loc: Northeast Pa

Posted: 8/15/2013 9:14:50 PM
Well I'm seriously having second thoughts about buying this. My laptop is broke and wont be fixed anytime soon so the whole wireless feature is what sold me but its not worth it to me if I'm going to have all these issues.

Glad the others got theirs fixes....sorry to the ones who haven't
Uploaded with iPhone client

paperpilekitten
PeaFixture

PeaNut 118,945
December 2003
Posts: 3,174
Layouts: 144
Loc: Stockholm, Sweden

Posted: 8/16/2013 2:25:52 AM
Polly, thank you so much for sharing that tip on how to get the Selphy to work again! As I said, mine just started to work again, one random day, but with the experiences I've had, I don't trust it to continue that way. :/

Show/Hide Icons . Show/Hide Signatures
Hide
{{ title }}
{{ icon }}
{{ body }}
{{ footer }}